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Introduction 

The guideline tool is one of the products of HarmoniQua. 

It is designed so as to present the available knowledge stored in the project's knowledge base 
in an efficient way. In order to achieve this aim, the tool communicates with the knowledge 
base in order to extract the required knowledge, process it and adapt its content and 
presentation to the needs of the user. 

The parameters affecting the tool's behaviour are the user type and expertise, the modelling 
domain, the modelling application or the modelling job. Given this information, the tool 
produces a working environment containing all necessary guidelines in an easy-to-navigate 
manner. The tool is designed with a simple and extensible software architecture to facilitate 
its use in a variety of application-specific processes. 

Users are able to navigate through the different tasks and find the information they want, 
print part or the whole of the guideline and filter out information that is not relevant for the 
specific user. 

User Interface 

Having completed the installation procedure, the application is initiated and the main 
interface appears.  

 

Figure 1: User interface of Guideline tool 
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The user interface (UI) of the guideline tool is shown in Figure 1. Three views appear: the 
Tree view on the left, the Flowchart view on the upper right and the Task view on the lower 
right part of the screen. As shown in the figure, the user interface of the guideline tool is 
familiar with popular applications. 

The user may enable or disable any one of the views. For example in the figure 2 we can see 
that the flowchart has been disabled. 

 

Figure 2: Disabled flowchart view. 

This can be easily done by clicking on the Expand - Collapse buttons as shown in the figure 
3. 
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Figure 3: Expand - Collapse butttons and the status bar. 

The status bar provides information about the filtering that is being applied at this moment. 
By clicking at the status bar a dialog appears that lets you modify these filters. 

The guidelines are composed of tasks that are a collection of knowledge items. Tasks are 
grouped in steps. Five distinct steps are identified, namely:  

• Purpose and Conditions  
• Conceptualisation  
• Model setup  
• Calibration and Validation  
• Prediction 

This structure is to a limited extent similar to a tree structure and the tool includes a tree view 
task navigator. As guidelines are best represented with flowcharts, the guideline tool has a 
flowchart view that is synchronised with the tree view. Synchronisation signifies that the task 
that is selected in the tree view is automatically selected in the guideline view and vice-versa. 
The guideline tool has a view for displaying detailed information about the selected task, the 
so-called task view. The task view shows the definition, explanation, methods, activities, etc 
of the selected task. As shown in Figure 1, the tool consists of a main menu supplemented 
with tool bars and a number of dialog windows. 

Any time you have a question about the use of the guideline, you can find help by pressing 
Ctrl + h or by the menu: (Help> Online help...). The guideline on-line help system will 
appear (Figure 4). By using this help system you can find information about the use of the 
guideline tool, the terms of the glossary that accompanies the guideline or even visit the 
HarmoniQua web site for news and updates. 

 
 

Figure 4: The Guideline on-line help system. 
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The Treeview 

As mentioned, the tasks are grouped in steps and this structure is to a limited extent similar to 
a tree structure. The so-called TreeView appears on the left of the interface and has the 
following form: 

 

Figure 5: The Treeview 

The tree view is automatically filtered and updated in order to conform to your requirements. 
By clicking any item of this view, its description will appear in the Task View and it will be 
highlighted in the Flowchart view. This is the quickest way to explore Guideline contents. 

The Flowchart 

The flowchart view is a representation of the guideline in flowchart form. This view looks 
like the one can be shown in figure 6 and has many features for quick and easy navigation. 

 

Figure 6: The flowchart view. 

Each step is given a distinct visual representation in the form of a flowchart (Figure 7). The 
most basic flowcharting symbols, which are essential to making the flowchart of the tool, are 
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nodes and arrows (flowlines). Three types of nodes appear, namely the task nodes, the 
decision nodes and the review nodes, which are the final nodes of each step. Arrows 
connecting the nodes show the direction of flow of the processes. The flowchart comprises of 
the following symbols that make it uniform and easier to read:  

• Arrows (flowlines) connect nodes and show direction of flow of the processes.  
• Rectangles represent task nodes, indicating work or actions that are to be performed 

(Figure 8). At least one flowline leads in a task node and at least one leads out of it.  
• Rhombi represent decision nodes, indicating that a choice is to be made (Figure 9). 

They are usually phrased as questions and, depending on the answer, two or more 
flowlines lead out of the nodes. Decision nodes have one flowline leading in and two 
or more leading out, depending on the decision that is to be made.  

• Octagons represent review nodes, indicating an assessment of the extent to which the 
work has been carried-out according to predefined objectives and specifications, i.e a 
review of all previous nodes and a decision whether to proceed with a next step 
(Figure 10).  

 

Figure 7: Flowchart for a specific step (step 1:Purpose and Conditions) 

 

Figure 8: Example of a task node 

 

Figure 9: Example of a decision node  

 

Figure 10: Example of a review node 

You can set a whole step in expanded/collapsed state by pressing the Expand/Collapse step 
buttons (Figure 11). With the help of this button you can easily show the steps that interest 
you and reduce the flowchart size. 
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Figure 11: Expand/Collapse step buttons. 

Active lines (Figure 12) let you quickly navigate through the flowchart. By letting the mouse 
over a line for a few seconds you can see the source or the destination of the line and the case 
that it represents if it's a decision or review line. By clicking on the line the view 
automatically focuses to the area of the source/destination of the line. 

 

Figure 12: Active lines let you quickly navigate through the flowchart. 

Additionally the user can easily scroll the flowchart by dragging its area that isn't covered by 
other items. 

 

The Task view 

The Task view contains information for each task, decision or review, in text and tabular 
form (Figure 13).  

 

Figure 13: The Task view components 

The user is provided with the option of viewing the bulk of the Task view elements or 
specific elements only, by enabling the various view options that exist and appear on the top 
of the view: The following items appear in the Task view: 

• Dedication aspects. These are presented in tabular form and show for which 
dedication aspect a specific task, decision or review is valid.  
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• Relations. This table provides information on the following:  
o Step indicates the step incorporating the specific task, decision or review  
o Previous task/Next task provide information regarding which is the previous 

and the following task of the process.  
o Feedback to/feedback from indicate whether there is feedback from/to a 

certain task, decision or review.  
• Formulation of Definition. This is a brief sentence defining the specific task.  
• Explanation of Definition. This is a paragraph providing the brief explanation of 

each task.  
• Methods. Under this heading, the adopted methodologies to achieve the task's goals 

are stated in tabular form.  
• Activities. This is a table describing the set of actions to be taken in order to achieve 

the goals of the task.  
• Software aspects. This section provides information on the software tools that may 

be used for the completion of the specific task.  
• References. This is a list of all reference material, including hyperlinks to relevant 

websites.  
• Input to/output from task. The final component of the task view comprises of the 

input required for the task to be carried out, and the expected output of the task.  

In a task view, someone can filter the Guideline information by selecting the "Task 
description", "Activities information", "Methods information" and "Full task information" 
tabs (Figure 13). Additionally we can see that some words in the task view appear 
highlighted. These are terms that exist in the accompanying glossary. If you click on these 
terms the "On-line help system" view appears and shows definition and other help for these 
terms (Figure 14). The terms are also subject to filtering of the "Domain type" of the filters. 
Terms highlighting can be turned off (for example for producing better printing results). This 
can be done by un-checking the "Highlight glossary terms" checkbox in the Help menu. 

 

Figure 14: Glossary help for the consultant term 
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The Menu 

The menu structure includes the following four items:  

File menu (Figure 15). 

 

Figure 15: The File menu. 

This menu contains the following file - related operations:  

• New profile: It creates a new untitled profile. The dialog of figure 16 appears. Via 
this dialog you can control the filter options of the profile. This will be explained in 
detail.  

 

Figure 16: Profile settings  
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When the Guideline tool is started for the first time or whenever a new profile is required, the 
user is presented with a dialog box querying him/her on guideline requirements and 
modelling aspects. In this intuitive manner, the Guideline Tool is provided with the required 
input and can proceed in removing guidelines that are irrelevant to the end user or to the 
modelling aspect. For practicality reasons, separate guidelines are generated for specific 
classes of use. To achieve these 'dedicated' guidelines, four dimensions are defined (Figure 
16). These dimensions are used to structure the knowledge in an optimal way for all users, 
domains, job complexities and application purposes.  

As seen in Figure 16, there are four aspects by which a guideline can be refined. The User 
type allows the user to specify his background, falling into one of the following categories:  

• Modeller  
• Manager  
• Auditor  
• General public.  

Application type refers to the user's purposes, which may fall into three categories:  

• Planning  
• Design  
• Operational Management.  

With the Domain type option, the user chooses the specific field of his/her study among the 
existing, which are the following:  

• Generic  
• Multi-domain  
• Groundwater  
• Precipitation-Runoff  
• Hydrodynamics  
• Flood forecasting  
• Surface water quality  
• Biota  
• Socio-economy.  

Finally, regarding the Job complexity, three options exist: 

• Basic  
• Intermediate  
• Comprehensive.  

• Load profile: Via this option, the user can load a profile that he/her has previously 
saved. By clicking this item a file select dialog appears and prompts the user to select 
a filename for the profile. Then if a valid profile is found, the profile is being 
restored.  

• Save profile: Via this option the user can save his/her profile for future use/reference. 
If the file hasn't been previously saved, a file select dialog appears in order to let the 
user select a file name.  

• Save profile as: The same with the previous one but the file select dialog always 
appears.  
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• Settings: Via this dialog, the user can select edit some file settings. These are limited 
to four filenames (Figure 17). For most of cases, the default values are perfect and no 
modification is required.  

o The Guideline XML document is the document that contains the guideline 
that is being used by this tool. This is the most important file for this tool and 
will not work without a valid guideline file. New guidelines can be 
downloaded by clicking on the Help > "Update the Guidelines...".  

o The Flowchart XML document. This is a document used for creating the 
flowchart view. This option enables the user to use different kind of flowchart 
representations.  

o The XSL transformation file. This file is being used for creating the task view 
of the Guideline.  

o The glossary XSL transformation file is being used in order to create the help 
for glossary terms.  

 

Figure 17: File settings 

• Print: This option lets the user print either the Flowchart view of the guideline or the 
document that is currently presented in the Task View.  

 

Figure 18: Print Options dialog. 

• Save to HTML: This option lets the user save to an HTML file the document that is 
currently presented in the Task View.  

• Exit menu: Via this option the user exits the program.  
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Edit menu (Figure 19) 

 

Figure 19: The edit menu. 

• Find: Shows a find dialog (Figure 20) that can be used for finding a word in the 
guideline step and task names or in the description currently shown in the Task view. 
It is convenient to use the Ctrl+F key shortcut.  

 

Figure 20: The find dialog. 

• Find Next: This finds the next occurrence of the word defined by the previous option 
(figure 20). It is convenient to use the F3 key shortcut.  

• Profile properties: This provides a profile settings dialog (Figure 16) and lets the 
user change current profile settings. Note that profile must be saved in order these 
settings to be persistent.  

 View menu (Figure 21) 

 

Figure 21: The View menu. 
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This menu contains commands related to viewing. 

• Previous View/Next View: This command lets the user see the task/step that was 
previously selected or move to the next selected task if one. This option lets the user 
recursively show every step the user has done, affecting all three views.  

• Zoom In/Zoom Out: This command lets the user zoom in and out to the flowchart 
view.  

• Expand All/Collapse All: Let the user expand/collapse all steps of the flowchart and 
the tree view.  

• Small/Medium/Large icons: This option lets the user select the icon size of the tree 
view of the guideline.  

• Toolbar: This check option let the user make the toolbar visible or not. The toolbar 
can be set invisible in order to save screen space.  

• Fixed font size: This check option if selected applies a fixed font over the flowchart 
view. This font is the minimum required in order to fit every step/task.  

• Select font: This option pops-ups a font select dialog that lets the user select the font 
that is being used for flowchart rendering.  

• Edit colors: Pop-ups a color edit dialog (Figure 22). Via this dialog one can 
customize every single color that exists in flowchart/tree view.  

 

Figure 22: The color edit dialog. 

 

Help menu (Figure 23) 

 

Figure 23: The Help menu. 
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This menu provides help information for the tool. 

• Online help...: Opens the on-line help system of the guideline tool that provides help 
for use of the guideline tool and glossary terms.  

• Glossary: Opens the on-line help system in the glossary sub-section. The whole 
glossary is presented.  

• Highlight glossary terms: This option affects the Term view of the Guideline. If 
checked, the glossary terms are being highlighted in the Term view and if the user 
clicks over them the on-line help system opens the appropriate glossary sub-section.  

• Update the guidelines: This option lets the user download the latest guideline from 
the internet.  

• About: This presents the people who created the guideline tool.  

 

The Toolbar 

The toolbar of the guideline tool is intended to improve user experience by providing fast 
access to frequently used item. 

 

Figure 25: Application toolbar 

The buttons are shortcuts to the corresponding menu options. These are presented from left to 
right. 

• New profile icon: Shortcut to File>New profile  
• Load profile icon: Shortcut to File>Load profile  
• Save profile icon: Shortcut to File>Save profile  
• Print icon: Shortcut to File>Print  
• Find icon: Shortcut to Edit>Find  
• Expand All icon: Shortcut to View>Expand all  
• Collapse All icon: Shortcut to View>Collapse all  
• Previous view icon: Shortcut to View>Previous view  
• Next view icon: Shortcut to View>Next view  
• Zoom in icon: Shortcut to View>Zoom in  
• Zoom out icon: Shortcut to View>Zoom out  
• Edit profile icon: Shortcut to Edit>Profile properties  
• Edit palette icon: Shortcut to View>Edit colors  

 


